Share FAQ

Trollbeater

Robin Hood of U15 Torrent
Jan 6, 2009
483
38
A few more questions. Thanks by the way for all the assistance.

1. I am downloading several files simultaneously. None are finished but the amount downloaded exceeds 4GB. Will that present a problem in my cache?

2. Is there a plugin to search by date of hash? In other words, can I put in a broad query such as '[IV][U15]' and specify only those files which proceed a certain date, in order to get only the most recent additions?
 

Rollyco

Team Tomoe
Oct 4, 2007
3,643
33
I am downloading several files simultaneously. None are finished but the amount downloaded exceeds 4GB. Will that present a problem in my cache?
No.

can I put in a broad query such as '[IV][U15]' and specify only those files which proceed a certain date
FYI there are no network-wide timestamps for hashes. Only when your Share client finds a DB trigger or initiates a download is a hash added to your database and locally timestamped. So if your "IV U15" trigger has been active for enough time, you can sort the query list (DB only, not Remote) by Last Update and get meaningful results.

If you're impatient, search with KeyDB and sort (並び順) by date added (登録日) in descending order (降順).
 

Fuurin

Active Member
Jan 27, 2008
343
68
Anyone know why my DL rate won't go above 30kb? While upload rates hits 50kb+
Your download speed has to do with the number of sources, their upload speed and the amount you yourself are uploading. There are no internal limits to download speed, so it can run very high indeed, if there are enough sources, and you are at the front of their queues.
 

biada

Member
Jan 28, 2008
33
2
OK, fixed it. It was user error. I confused the upload / download box and entered the wrong numbers..

My UL rate was 900kbs, and DL rate was 50kbs. I just switched it and its now getting up to 600-650 kbs.
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
I'd just bought a new router modem, but I configured it as a "bridge connection".
My PC connect to it directly.
So I fired up ShareEX, and got the error port message as usual.
Now I wonder, I'd set the router modem as "bridge connection", if I'm not wrong, I shouldn't have to bother port forwarding... Why I still got such error??
Really bugs me... Please advice, because my networking skill is lousy... LOL~
 

guy

(;Θ_Θ)ゝ”
Feb 11, 2007
2,282
46
I'd just bought a new router modem, but I configured it as a "bridge connection".
My PC connect to it directly.
So I fired up ShareEX, and got the error port message as usual.
Now I wonder, I'd set the router modem as "bridge connection", if I'm not wrong, I shouldn't have to bother port forwarding... Why I still got such error??
Really bugs me... Please advice, because my networking skill is lousy... LOL~

Yes a bridge connection does not need port forwarding. However setting up a bridge connection correctly is a bit more complicated than simply using a basic router/hub mode, and if done incorrectly can break some network functionality.

To explain it simply, bridging forwards data according to a network interface's hardware/MAC address rather than its assigned IP address (which is why port forwarding doesn't matter), and therefore is best suited for connecting multiple local networks (eg: a group of computers with 172.16.x.x IP addresses and another group with 192.168.x.x IP addresses can all connect to a "bridge" and see each other via MAC addresses, even though the IP addresses are outside of their respective scopes).

Since I don't know exactly how your network is set up, I can't say if bridging makes sense for you or not. But if your router is a typical router, the bridging is probably only happening between the LAN ports, and not from the WAN to the LAN (for which you would probably need some NAT rules). If you have fewer than a handful of networked devices on your local network, bridging doesn't really offer anything over regular routing anyway. And unless you need a very specific setup, it's actually easier to just set port forwarding, rather than digging through your router and Windows network configs.
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
jupiter999, did you put the port TCP in and out into the firewall settings?

I'm using ESET Smart Security 4.0.314.0 atm. So I'd disable Windows Firewall... But still I'd done something like the 1st pic.

I'm always doubting if I had done something wrong...:dunno:

Really appreciate if you can explain everything in your way:chinesenewyearm:


Yes a bridge connection does not need port forwarding. However setting up a bridge connection correctly is a bit more complicated than simply using a basic router/hub mode, and if done incorrectly can break some network functionality.

To explain it simply, bridging forwards data according to a network interface's hardware/MAC address rather than its assigned IP address (which is why port forwarding doesn't matter), and therefore is best suited for connecting multiple local networks (eg: a group of computers with 172.16.x.x IP addresses and another group with 192.168.x.x IP addresses can all connect to a "bridge" and see each other via MAC addresses, even though the IP addresses are outside of their respective scopes).

Since I don't know exactly how your network is set up, I can't say if bridging makes sense for you or not. But if your router is a typical router, the bridging is probably only happening between the LAN ports, and not from the WAN to the LAN (for which you would probably need some NAT rules). If you have fewer than a handful of networked devices on your local network, bridging doesn't really offer anything over regular routing anyway. And unless you need a very specific setup, it's actually easier to just set port forwarding, rather than digging through your router and Windows network configs.

Gosh~ Bridge connection is much difficult than I thought!

By the way, I got another router modem in my office.
I'd forward the port as instructed, but the port seems closed as ever...
I'd attached some pics for reference...

My TCP/IP setting is shown in the first pic.
Then, my office router modem GUI is shown in the second pic.
Did I forward the port correctly?
I'd checked it from hxxp://www.canyouseeme.org/
The result is shown in the third pic.

My uTorrent seems cannot blast its way through an open port... The port that I'd chose is 34432

Please advice...
Thanks again...
 

guy

(;Θ_Θ)ゝ”
Feb 11, 2007
2,282
46
I'm going to ignore the fact that your Windows Firewall exception says port 44241, while your router config says port 34432, and say that your settings look fine (as long as your ESET firewall software isn't causing the problem). But I'm still not sure exactly how your network is set up. Something like this would help:

Code:
Computer —(lan cable)→ [Router] —(lan cable)→ [ADSL/Cable Modem] —(coax/modular line)→ {ISP/Internet}

You mentioned you have another router in your office. If your computer must go through the office router (as well as your "new" router) in order to connect to the internet, then depending on exactly how they're connected, you may need to enable port forwarding on both routers.

Basically almost every device in your network must go through some configuration. Except the ADSL/Cable modem, since that should be configured as a bridge by default and should not require any special settings).

If it's the case that your new router sits behind your office router like this:

Code:
Computer —(lan cable)→ [New Router] —(lan cable)→ [Office Router] —(lan cable)→ [ADSL/Cable Modem] —(coax/modular line)→ {ISP/Internet}

...Then indeed it would make sense to set your new router to function as a bridge (allowing it to connect transparently to the network managed by the office router). But you will need to configure the office router to forward ports to the correct IP address as usual.




One note about canyouseeme.org and other sites like it: make sure you disable your firewall software before running that test. Programs like PeerGuardian will block non-port-80 (http) requests originating from websites, meaning that a test on a non-standard port will always fail.
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
Gosh~ Sorry guy that I'd confused you...
The new router modem sits in my home, while the office router modem never connect with each other. I bring them up just to make some research only. Partly my learning process.

Office router modem was configured as normal networking, so I'll have port forwarding section. Meanwhile, my new home router modem was configured as bridge, so I don't have port forwarding section.

Let's talk about office first. So for the office router modem, I'd forward port 34432. Then my uTorent and ShareEx had been configured to use port 34432. So uTorrent are very slow, while ShareEx disconnected as always. Then I went to canyouseeme.org to check port 34432. It is closed!

Gosh~ I'm blurred... Feels like I did something wrong...
 

guy

(;Θ_Θ)ゝ”
Feb 11, 2007
2,282
46
Unless you never use uTorrent and ShareEX at the same time, you should not have them configured to use the same ports. It can cause a lot of interference and can slow down or break your connections. This is a general rule of thumb for most (if not all) P2P applications.

If your router supports it, you can opt to forward a range of ports to your computer (such as 30000-39999, and not just the single port 34432). Then you can just configure your P2P apps to use ports within that range.

In the case of uTorrent, you may still have to also forward ports 6881-6889. While bittorrent will work with any port you specify (as long as it isn't already used by another protocol, like port 80 for HTTP or port 21 for FTP), some trackers will only accept connections in the standard bittorrent port range (6881-6889), and if you cannot connect to the tracker then your torrents may never move.



If your Windows firewall is disabled, you do not need to add port or application exceptions. If you are using ESET or any other software firewall/filter, you must check its help pages on how to add exceptions. A quick way to see if ESET is the problem (or if you haven't configured it correctly) is to just disable it temporarily and see if uTorrent/ShareEX work properly. If they do, then you know your network is configured correctly, but ESET is not.
 

Rollyco

Team Tomoe
Oct 4, 2007
3,643
33
some trackers will only accept connections in the standard bittorrent port range (6881-6889)
Actually the default setting for many trackers is to blacklist that port range.
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
Don't worry, I won't fire up uTorrent and ShareEX at the same time, I know this.

And yes, I'd even forward a range of ports from 1000 to 50000, and I'd tried a few ports into uTorrent and ShareEX, no one seems to be working...
Hmmm, what am I doing??

I begin to suspect my firewall, so I'd disable them. But what surprised me is I'm still having the same network condition~ The ports are still closed...

Sounds like I'm gonna open up an X-File study with both my modems...

Thanks again guy, and I'll be looking forward to your advices from time to time.
 

Faxman

New Member
Mar 29, 2009
21
0
I can't seem to get Share to work no matter what I try. Several attempts at port forwarding, switching the router to bridge mode, bypassing the router and doing a direct connection, disabling my antivirus program, disabling Windows firewall... I still get disconnected after a few minutes because of that dreaded port error. Anyone have any suggestions?
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
I can't seem to get Share to work no matter what I try. Several attempts at port forwarding, switching the router to bridge mode, bypassing the router and doing a direct connection, disabling my antivirus program, disabling Windows firewall... I still get disconnected after a few minutes because of that dreaded port error. Anyone have any suggestions?

Exactly the same as me...
 

Rollyco

Team Tomoe
Oct 4, 2007
3,643
33
Start Share EX2, Visit http://www.canyouseeme.org/, past your Share port (the one configured in General Settings > Network > Port), and click the Check button. The website should return "Success: I can see your service", and "Your ISP is not blocking port xxxxx".
 

Faxman

New Member
Mar 29, 2009
21
0
Start Share EX2, Visit http://www.canyouseeme.org/, past your Share port (the one configured in General Settings > Network > Port), and click the Check button. The website should return "Success: I can see your service", and "Your ISP is not blocking port xxxxx".

I gave it a shot and it says that it could NOT see my service. I tried several ports, two different computers, and I again went with a direct connection, firewall and anti-virus off. Any ideas?
 

Rollyco

Team Tomoe
Oct 4, 2007
3,643
33
Well, something other than Share is preventing the outside world from reaching you at that port. Questions:

  1. Did you try a high port number like, say, 32001?
  2. If you're running Vista or Windows 7, did you try running Share as an Administrator?
  3. When you said you tried a direct connection, does that mean you connected your DSL modem directly to your computer with an ethernet cable? Or was there any other device (like a wired/wireless router) in between?
  4. Are you sure you have disabled the Windows built-in firewall?
  5. Are you sure you have disabled any other third-party software firewalls or internet-aware antivirus stuff? Try uninstalling them, just in case.
 

jupiter999

loves Tada Mizuho only...
Apr 2, 2008
516
0
Did you try a high port number like, say, 32001?

Tried several... Same failures...

If you're running Vista or Windows 7, did you try running Share as an Administrator?

I'm suing Windows XP...

# When you said you tried a direct connection, does that mean you connected your DSL modem directly to your computer with an ethernet cable? Or was there any other device (like a wired/wireless router) in between?

Router modem configured as bridge, then direct connection between my PC and this reconfigured router modem with ethernet cable...

Are you sure you have disabled the Windows built-in firewall?

Yes.

Are you sure you have disabled any other third-party software firewalls or internet-aware antivirus stuff? Try uninstalling them, just in case.

I'm using ESET Smart Security. I'd disabled it. But no use... The port is still closed!
Haven't try uninstall it...

Below is my result from http://www.canyouseeme.org/

Error: I could not see your service on 60.54.20.61 on port (24444)
Reason: Connection timed out


Please, help me... I'd run out of ideas...