1. Akiba-Online is sponsored by FileJoker.

    FileJoker is a required filehost for all new posts and content replies in the Direct Downloads subforums.

    Failure to include FileJoker links for Direct Download posts will result in deletion of your posts or worse.

    For more information see
    this thread.

meguIV: The Official Akiba-Online DVD Encoder (v1.0.1.1)

Discussion in 'Tech Support' started by Rollyco, Jun 30, 2009.

  1. shank

    shank Member

    Thanks for explaining all those components. In my free time I will keep trying to figure out the individuals.

    I'm running Win8.1 (64bit). This version runs properly without errors. I changed the x264 settings to my usual Very Slow and CRF 18, and it encoded properly without errors. Looks good so far.

    My AV is Eset NOD32 and it did not complain.
    SamKook likes this.
  2. Menauer

    Menauer Member

  3. SamKook

    SamKook Akiba Citizen Uploader

    The new version of the sandbox has the possibility of doing stuff from a server like being hosted there and people not even having to download the software so it could be related to that.

    I'll check if there's an option I forgot to uncheck(I didn't look too much, most things were left to the defaults) to prevent this from happening.
    Performant likes this.
  4. Performant

    Performant Member

    Exactly.

    This feature deletes and essentially overwrites any of the .dll, .exe or any other components in a predefined set, which keeps me from updating or replacing those depending on my needs at the moment. This, I believe, is also what keeps triggering antivirus warnings, too.

    If this issue is resolved, your repacked version will be my primary encoding setup, and I won't have to waste 60+ minutes rebooting over and over every time Windows Update brings something along. And much more importantly, I'd finally be able to migrate to Windows 8.1 or 10 if the need arises. Great job, SamKook!

    BTW, maybe it'd be a good idea and minimize confusion if you gave each of your releases its own version number such as MeguiVit 1.0.0.0.b4 SamKook 1.0 or something shorter.
  5. SamKook

    SamKook Akiba Citizen Uploader

    I wasn't suggesting the server hosting stuff option was enabled since it's not something that can be done without me knowing and it would have cost a lot of money to even set up, but I thought it might always check if the possibility exist of having stuff there.

    I checked the options and there's nothing I can do to prevent this since I can't see any options I can change that would imply the need to access something remote.

    After a bit of wiresharking, it seems to be validating an encryption certificate with spoon.net and it downloads something from comodoca(a certificate authority website) which we can safely assume is certificate related.

    My guess is that the software always check if the company ssl certificate is valid in case it needs to eventually talk to the server and it downloads it locally if it's not there or up-to-date.
    This shouldn't be something to be too much worried about, but it could be a good idea to block the application from accessing the web in windows firewall since it may be checking that certificate because it does need to call back home, possibly to gather data of some kind.
    There's nothing I can do about it and I'm not expert enough to know exactly what it's doing, but blocking it in the firewall will ensure it doesn't do anything bad and it shouldn't block it from working properly.

    As for the release version, I gave that one the name beta4_Repacked_2015-12-02 since it's pretty much identical to vitreous beta 4 release(except x264), but I was planning on giving it a different nomenclature If I actually start changing some stuff.
  6. Menauer

    Menauer Member

    Thanks for clarifying SamKook. If you update it, please change the title bar to beta 4 instead of 3, if it's not too much hassle.
  7. SamKook

    SamKook Akiba Citizen Uploader

    I wish I could, but I'm pretty sure Vitreous had to modify the source code of MeGUI to make his version and I don't have access to that so unless I redo all of his changes using a more recent vanilla MeGUI(that would be a lot of work for pretty much zero gain so I won't do that), I won't be able to change it unless I disassemble the exe, find the right assembly code to modify and reassemble it which would also be quite a bit of work since assembly isn't exactly easy to understand and I haven't touched it in years.

    I was hoping it would be stored as a resource in the exe which I could have easily modified with resource hacker or that it would be in plain text somewhere in the exe once open with an hex editor, ready to be modified, but no such luck.
  8. Menauer

    Menauer Member

    Allright, so I just tried to use this new version for the first time but unfortunately it doesn't work. It creates the audio files and other stuff, but when it is supposed to start encoding the h264 file it simply doesn't do anything, and if I check the log there is an error that says the mencoder.exe file is missing.
  9. SamKook

    SamKook Akiba Citizen Uploader

    Hmm, that's odd. If it says mencoder is missing, it's not the step where it starts encoding the h264 file, it's the step where it does the lossless file before encoding it to h264. If you uncheck "Add pre-rendering job" in the encoder config tab, it will skip that step and encode it directly using h264 without needing to use mencoder so that can be a temporary fix.

    Can you tell what OS you're using, if it's a 32 or 64 bit one, what video profile you used and confirm that you have a C: drive(just in case but I doubt that would cause problems either way)?
    Also, try to delete the sandbox folder and start the exe again just to make sure it's not trying to use an old sandbox folder. It doesn't need a sandbox folder, it will create it's own unlike the previous version of MeguIVit which had to replace the one from MeguIV.
  10. Menauer

    Menauer Member

    I'm using Windows 7 64 bit, and the 480p 60fps Quality+3 slightly modified. I disabled pre-rendering and got "x264.exe' is missing", so with the same sort of thing happening twice, I figured that "shame on me", there has to be something wrong at my end. I deleted the sandbox folder as you said and got a different error at another point, deleted it again and got an error at startup... Long story short, Panda Free Antivirus silently screws it an all sorts of ways even with all notification settings enabled, and behavioural options disabled.
    Funny thing is that I usually have my antivirus disabled, especially when encoding, so maybe the same thing would actually happen here with the old MeguIVit.
    Last edited: Dec 26, 2015
  11. SamKook

    SamKook Akiba Citizen Uploader

    The antivirus is a likely candidate for blocking those that I didn't think about, they don't like "invisible" exe being executed without the user really knowing about it.
  12. eshwaa

    eshwaa Well-Known Member

    So far I've had luck with MeguIVit 480p 60fps Detail +2 as my go-to encode setting, but I'm having trouble with some videos with a "halo-effect". I've read some posts in this thread by Vitreous how edgeclean can help, but the encodes are failing. I tried encoding a second time to get the specific error, but I didn't get a dialogue box this time. The audio and video went through the encoding process, but there was a process that failed to start.
  13. SamKook

    SamKook Akiba Citizen Uploader

    If you go in the queue tab, you can see all the steps and if one failed or not.

    I just started an encode with your preset and edgeclean checked to test and it's at the step where edgeclean is applied(that would be the first video step) and it hasn't failed or made any error so far. I'll let it run to see how it goes, but it looks fine so far and if you say the video step completed, edgeclean shouldn't affect any other step so that's odd.

    Maybe there's other settings you're using or not using that are affecting it, details on everything you changed from default or screenshots of the settings tab would be helpful in trying to replicate the problem.


    Edit: I may have spoken too soon, looks like the extra processing from edgeclean makes mencoder crash after a few minutes every time on my test computer meaning you likely can't use the default Threading options, you'd either have to increase the cache memory(which can be tricky, I'm pretty sure vitreous talked about it somewhere in here) and/or reduce the amount of threads.

    Also, when you get an encode that crashes, it's a good idea to clear the queue first before starting a new encode since it will likely try to resume the previous one when you launch the new one and skip the step that failed. Deleting the sandbox folder also achieve the same thing.

    You can also right click the failed step in the queue tab, change it's status to waited and retry it if you want to keep the exact same settings, but retry it for some reason(there's a good chance it will fail again though since nothing changed, depending on the problem).
    Last edited: Jan 15, 2016
    eshwaa likes this.
  14. Menauer

    Menauer Member

    Trying to do some things with Avidemux. What filter should I use from this list to get high quality deinterlacing like MeguIVit does?

    [​IMG]
  15. SamKook

    SamKook Akiba Citizen Uploader

    None of them. Meguivit uses qtgmc which is the quick version of tgmc with a few other stuff around it and nothing native to avidemux comes close to it in term of quality.

    You'd have to use an avisynth script with qtgmc and load that in avidemux.
    Menauer likes this.
  16. Menauer

    Menauer Member

    Okay thank you SamKook, I've been googling and it seems really complicated to do because of obscure dependencies and whatnot. Also the information I found might be outdated, so I'd appreciate any help doing that.
  17. SamKook

    SamKook Akiba Citizen Uploader

    First, download one of the avisynth 2.6.1 version there(the difference are the dependencies since they're testing switching to new compilers): https://sourceforge.net/projects/av..._Alpha_Releases/AVS 2.6.1 Alpha 1 [20160517]/

    As for the dependencies, read the text below the download, it will explain all of them.

    Then install the qtgmc plugin from here(there's a version 3.33 later in the thread that wasn't officially released kind of, doesn't change much): http://forum.doom9.org/showthread.php?t=156028

    Last thing left to do is to create a .avs file that loads your video and audio source and apply the qtgmc filter and load that with avidemux(assuming you still have other stuff to do with the video, if not you can use any other encoder you want) instead of your video. The avisynth wiki and the qtgmc readme are your friends here.

    Edit: Actually, you might need to load the script with avsproxy to load it in avidemux. It's not something I've done often so I don't quite remember but googling how to open an avisynth script with avidemux will tell you how.
    Last edited: Dec 28, 2016
    CoolKevin and Menauer like this.